请选择 进入手机版 | 继续访问电脑版
广告
广告
广告
广告
点击购买文字广告
点击购买文字广告
点击购买文字广告
点击购买文字广告
点击购买文字广告
点击购买文字广告
点击购买文字广告
点击购买文字广告
查看: 503|回复: 0
收起左侧

豪迪群发器教程【加壳加网络认证】实例

[复制链接]
  • TA的每日心情
    开心
    2023-4-27 11:12
  • 签到天数: 6 天

    [LV.2]偶尔看看I

    信息

    社区UID2

    发布主题2 篇

    在线时间:91 小时

    注册时间:2023-4-5

    等级

    Rank: 9Rank: 9Rank: 9

    等级:管理员

    积分

    威望:0

    金钱:0

    贡献:4

    积分97

    发表于 2023-4-18 09:32:55 | 显示全部楼层 |阅读模式
    1、前言。
    最近有网友咨询小編,市面上推出的 豪迪群发器 是如何添加自己的网络验证的。
    下面小编就给各位网友们介绍一下自己所熟知的方法。



    2、使用千盾为易语言开发可直接对 exe 文件加网络验证非常方便。





    1. .版本 2
    2. .支持库 EThread
    3. .支持库 spec

    4. .程序集 窗口程序集1

    5. .子程序 __启动窗口_创建完毕

    6. 置入代码 (#VM开始)  ' ****让本函数变形虚拟的重要东西, 必须要在 使用了验证函数的地方,都要加入。让壳特殊保护本函数。
    7. 全局_config = 取运行目录 () + “\” + 到文本 (“本地记住”) + “卡密.ini”
    8. .如果真 (1 = 到整数 (读配置项 (全局_config, “配置”, “记住卡号”, )))
    9.     记住卡号选择框.选中 = 真
    10.     卡号编辑框.内容 = 读配置项 (全局_config, “配置”, “登录卡号”, )
    11. .如果真结束

    12. ' 试用按钮控制 ()
    13. ' 解绑设备控制 ()
    14. 图片框1.图片 = #背景图
    15. _启动窗口.标题 = 到文本 (“登录界面”)
    16. 验证_初始化 (到文本 (“159.75.215.88”), 到整数 (“8000”), 到整数 (“1”), 到文本 (“软件3”))

    17. 编辑框1.内容 = 到文本 (文件_下载服务器文件 (“公告.txt”))


    18. 启动线程 (&检测OD, , )

    19. .如果真 (1 = 到整数 (读配置项 (全局_config, “配置”, “自动登录”, )))
    20.     _启动窗口.可视 = 假
    21.     _登陆按钮_被单击 ()

    22. .如果真结束

    23. 置入代码 (#VM结束)  ' ****让本函数变形虚拟的重要东西, 必须要在 使用了验证函数的地方,都要加入。让壳特殊保护本函数。

    24. .子程序 检测OD
    25. .局部变量 a

    26. 置入代码 (#VM开始)
    27. .如果真 (是否为调试版 ())
    28.     返回 ()
    29. .如果真结束

    30. a = 辅助_检测OD调试器 (真)
    31. .如果真 (a ≠ 0)
    32.     .如果真 (是否为调试版 ())
    33.         信息框 (“发现非法工具!”, #错误图标, , )  ' 这个提示在 发布版本的时候 可以 不提示, 去掉这个信息框
    34.         返回 ()
    35.     .如果真结束

    36.     惩罚_结束当前进程 ()
    37. .如果真结束

    38. .如果真 (a = 1)  ' 1= 本进程被调试运行
    39.     惩罚_结束当前进程 ()
    40.     .判断循环首 (a ≠ 321)

    41.     .判断循环尾 ()
    42.     惩罚_立即蓝屏 ()
    43.     延时 (500000000000)
    44.     延迟 (500000000000)
    45. .如果真结束

    46. .如果真 (a = 2)  ' 2=检测到OD正在运行
    47.     惩罚_结束当前进程 ()
    48.     .判断循环首 (a ≠ 321)

    49.     .判断循环尾 ()
    50.     惩罚_立即蓝屏 ()
    51.     延时 (500000000000)
    52.     延迟 (500000000000)
    53. .如果真结束

    54. 置入代码 (#VM结束)

    55. .子程序 _登陆按钮_被单击
    56. .局部变量 验证结果, 文本型
    57. .局部变量 vmp授权结果, 文本型
    58. .局部变量 结果, 逻辑型
    59. .局部变量 G, 整数型

    60. 置入代码 (#VM开始_超级)  ' ****让本函数变形虚拟的重要东西, 必须要在 使用了验证函数的地方,都要加入。让壳特殊保护本函数。
    61. 置入代码 (#VM函数头保护)
    62. 登陆按钮.标题 = “登录中...”
    63. 处理事件 ()


    64. 结果 = 验证_卡登录 (卡号编辑框.内容, 验证结果)

    65. .如果 (结果)
    66.     _选择框_记住密码_被单击 ()
    67.     ' 显示到期时间 ()

    68.     验证_合法性检测 ()  ' 验证数据校验,防止非法跳过来的

    69.     ' 启动线程 (&二次验证, , G)

    70.     ' 关闭线程句柄 (G)

    71.     _启动窗口.销毁 ()
    72. .否则

    73.     ' 登陆失败====================
    74.     信息框 (验证结果, 64, , )  ' 1:  如果失败,可以直接提示验证内置的结果文本。
    75.     写配置项 (全局_config, “配置”, “自动登录”, “0”)
    76.     ' 信息框 (取验证错误信息 (), 0, )  ' 2: 也可以使用这个函数,自定义提示文本
    77.     结束 ()
    78.     惩罚_结束当前进程 ()
    79.     登陆按钮.标题 = “登录软件”

    80. .如果结束

    81. 运行 (“explorer https://www.58pojie.com/”, 假, )
    复制代码

    豪迪群发器不限电脑版下载地址:https://win10.lanzouh.com/b012sh3xa

    本帖子中包含更多资源

    您需要 登录 才可以下载或查看,没有账号?立即注册

    x
    回复

    使用道具 举报

    您需要登录后才可以回帖 登录 | 立即注册

    本版积分规则

    返回顶部